NumericInputPropertyEditor Class

Numeric Input Property Editor registered for the "number" type name and "numeric-input" editor name. It uses the NumericInputEditor React component.

Extends

Methods

Name Description
constructor(): NumericInputPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void Inherited PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  

Properties

Name Type Description
containerHandlesEnter Accessor ReadOnly boolean    
reactNode Accessor ReadOnly React.ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesBlur Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesEscape Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesTab Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerStopsKeydownPropagation Accessor Inherited ReadOnly boolean PropertyEditorBase  
customDataController Inherited undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 27 February, 2025