EditorProps<TMetadata, TValue> Interface

Generic editor props that are supplied to the editor for rendering.

Properties

Name Type Description
cancel () => void | undefined Callback that allows editor implementation to indicate that editing is cancelled.  
commit () => void | undefined Callback that allows editor implementation to indicate that editing is finished.  
disabled boolean | undefined    
TMetadata    
onChange (value?: TValue) => void    
size "small" | "large"    
value TValue | undefined    

Defined in

Last Updated: 17 April, 2025