PopupItemProps Interface

Deprecated  in 4.16.0. Props of deprecated PopupItem component.

Properties of PopupItem component.

Extends

Properties

Name Type Description
hideIndicator boolean | undefined Describes if expandable item triangle indicator should be hidden.  
keepContentsMounted boolean | undefined If true the popup panel is mounted once and unmounted when button is unmounted.  
panel React.ReactNode | undefined Panel of the toolbar.  

Inherited properties

Name Type Inherited from Description
addGroupSeparator Inherited boolean | undefined ToolbarButtonItemProps If true add a gap before button.
badge Inherited React.ReactNode | undefined ToolbarButtonItemProps A badge to draw.
className Inherited string | undefined ToolbarButtonItemProps Custom CSS class name
groupPriority Inherited number | undefined ToolbarButtonItemProps value added to DOM element as a data attribute
icon Inherited React.ReactNode | undefined ToolbarButtonItemProps button icon.
isActive Inherited boolean | undefined ToolbarButtonItemProps Describes if item is active.
isDisabled Inherited boolean | undefined ToolbarButtonItemProps Describes if the item is disabled.
itemId Inherited string | undefined ToolbarButtonItemProps Optional unique identifier for item.
itemPriority Inherited number | undefined ToolbarButtonItemProps value added to DOM element as a data attribute, shows 0 is undefined
onClick Inherited () => void | undefined ToolbarButtonItemProps Function called when the item is clicked.
onKeyDown Inherited (e: React.KeyboardEvent<Element>) => void | undefined ToolbarButtonItemProps Function called when a key is pressed.
providerId Inherited string | undefined ToolbarButtonItemProps value added to DOM element as a data attribute to hold name of items provider.
style Inherited React.CSSProperties | undefined ToolbarButtonItemProps Custom CSS style properties
title Inherited string ToolbarButtonItemProps Title for the item.

Defined in

Last Updated: 30 January, 2025