Point2dTypeConverter Class

Point2d type converter.

Extends

Methods

Name Description
constructor(componentConverterName?: string): Point2dTypeConverter    
constructPoint(values: Primitives.Point): undefined | ConvertedPrimitives.Point2d Protected    
getVectorLength(point: Primitives.Point): undefined | number Protected    

Inherited methods

Name Inherited from Description
convertFromString(value: string): undefined | ConvertedPrimitives.Point Inherited BasePointTypeConverter Converts a string to a primitive value
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> Inherited BasePointTypeConverter Converts a string with a property record to a property value
convertFromStringWithOptions(value: string, _options?: [key: string]: any): undefined | ConvertedPrimitives.Value | Promise<Value undefined> Inherited BasePointTypeConverter
convertPropertyToString(propertyDescription: PropertyDescription, value?: Primitives.Value): string | Promise<string> Inherited BasePointTypeConverter Converts a value associated with a property description to a string
convertToString(value?: Primitives.Point): string | Promise<string> Inherited BasePointTypeConverter Converts a primitive value to a string
convertToStringWithOptions(value?: Primitives.Value, _options?: [key: string]: any): string | Promise<string> Inherited BasePointTypeConverter Default implementation just calls convertToString with no options
isEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean Inherited BasePointTypeConverter Determines if two primitive values are equal
isNotEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean Inherited BasePointTypeConverter Determines if two primitive values are not equal
isNotNull(value: Primitives.Value): boolean Inherited BasePointTypeConverter Determines if a primitive value is not null or not undefined
isNull(value: Primitives.Value): boolean Inherited BasePointTypeConverter Determines if a primitive value is null or undefined
sortCompare(a: Primitives.Point, b: Primitives.Point, _ignoreCase?: boolean): number Inherited BasePointTypeConverter Sort function for two primitive values

Inherited properties

Name Type Inherited from Description
componentConverterName Inherited string BasePointTypeConverter  
isBooleanType Accessor Inherited ReadOnly boolean BasePointTypeConverter Determines if the converter is for a boolean type
isLessGreaterType Accessor Inherited ReadOnly boolean BasePointTypeConverter Determines if the converter is for a numeric type
isNullableType Accessor Inherited ReadOnly boolean BasePointTypeConverter Determines if the converter is for a nullable type
isStringType Accessor Inherited ReadOnly boolean BasePointTypeConverter Determines if the converter is for a string type

Defined in

Last Updated: 30 January, 2025