BasePointTypeConverter Class

Point type converter.

Extends

Extended by

Methods

Name Description
constructor(componentConverterName: stringStandardTypeNames.Double): BasePointTypeConverter    
constructPoint(_values: Primitives.Point): undefined | ConvertedPrimitives.Point Protected Abstract    
convertFromString(value: string): undefined | ConvertedPrimitives.Point Converts a string to a primitive value  
convertToString(value?: Primitives.Point): string | Promise<string> Converts a primitive value to a string  
getVectorLength(point: Primitives.Point): undefined | number Protected Abstract    
sortCompare(a: Primitives.Point, b: Primitives.Point, _ignoreCase?: boolean): number Sort function for two primitive values  

Inherited methods

Name Inherited from Description
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> Inherited TypeConverter Converts a string with a property record to a property value
convertFromStringWithOptions(value: string, _options?: [key: string]: any): undefined | ConvertedPrimitives.Value | Promise<Value undefined> Inherited TypeConverter
convertPropertyToString(propertyDescription: PropertyDescription, value?: Primitives.Value): string | Promise<string> Inherited TypeConverter Converts a value associated with a property description to a string
convertToStringWithOptions(value?: Primitives.Value, _options?: [key: string]: any): string | Promise<string> Inherited TypeConverter Default implementation just calls convertToString with no options
isEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean Inherited TypeConverter Determines if two primitive values are equal
isNotEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean Inherited TypeConverter Determines if two primitive values are not equal
isNotNull(value: Primitives.Value): boolean Inherited TypeConverter Determines if a primitive value is not null or not undefined
isNull(value: Primitives.Value): boolean Inherited TypeConverter Determines if a primitive value is null or undefined

Properties

Name Type Description
componentConverterName string    

Inherited properties

Name Type Inherited from Description
isBooleanType Accessor Inherited ReadOnly boolean TypeConverter Determines if the converter is for a boolean type
isLessGreaterType Accessor Inherited ReadOnly boolean TypeConverter Determines if the converter is for a numeric type
isNullableType Accessor Inherited ReadOnly boolean TypeConverter Determines if the converter is for a nullable type
isStringType Accessor Inherited ReadOnly boolean TypeConverter Determines if the converter is for a string type

Defined in

Last Updated: 30 January, 2025