PropertyDataFiltererBase Class
An abstract implementation of IPropertyDataFilterer to share common behavior between different implementations.
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(): PropertyDataFiltererBase | ||
categoryMatchesFilter(node: PropertyCategory, parents: PropertyCategory[]): Promise<PropertyDataFilterResult> Abstract | ||
recordMatchesFilter(node: PropertyRecord, parents: PropertyRecord[]): Promise<PropertyDataFilterResult> Abstract |
Properties
Name | Type | Description | |
---|---|---|---|
isActive Accessor Abstract ReadOnly | boolean | ||
onFilterChanged | PropertyFilterChangeEvent |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.