VirtualizedPropertyGridProps Interface
Properties for VirtualizedPropertyGrid React component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
dataProvider | IPropertyDataProvider | Property data provider used by the property grid | |
eventHandler | IPropertyGridEventHandler | Handler of the events raised from the property grid | |
height | number | Height of the property grid component. | |
highlight | PropertyGridContentHighlightProps | undefined | Properties for highlighting property data in the grid. | |
model | IPropertyGridModel | Property grid view model that defines what needs to be rendered | |
propertyCategoryRendererManager | PropertyCategoryRendererManager | undefined | Custom property category renderer manager. | |
width | number | Width of the property grid component. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
actionButtonRenderers Inherited | ActionButtonRenderer[] | undefined | CommonPropertyGridProps | Array of action button renderers. |
actionButtonWidth Inherited | number | undefined | CommonPropertyGridProps | Fixed action button column width |
alwaysShowEditor Inherited | (property: PropertyRecord) => boolean | undefined | CommonPropertyGridProps | Callback to determine which editors should be always visible |
className Inherited | string | undefined | CommonPropertyGridProps | Custom CSS class name |
horizontalOrientationMinWidth Inherited | number | undefined | CommonPropertyGridProps | The minimum width before the auto-switch to Vertical when the width is too narrow. |
isOrientationFixed Inherited | boolean | undefined | CommonPropertyGridProps | Indicates whether the orientation is fixed and does not auto-switch to Vertical when the width is too narrow. |
isPropertyEditingEnabled Inherited | boolean | undefined | CommonPropertyGridProps | Enables/disables property editing |
isPropertyHoverEnabled Inherited | boolean | undefined | CommonPropertyGridProps | Enables/disables property hovering effect |
isPropertySelectionEnabled Inherited | boolean | undefined | CommonPropertyGridProps | Enables/disables property selection |
isPropertySelectionOnRightClickEnabled Inherited | boolean | undefined | CommonPropertyGridProps | Enables/disables property selection with right click |
itemId Inherited | string | undefined | CommonPropertyGridProps | Optional unique identifier for item. |
minLabelWidth Inherited | number | undefined | CommonPropertyGridProps | Minimum allowed label column width, after which resizing stops |
minValueWidth Inherited | number | undefined | CommonPropertyGridProps | Minimum allowed value column width, after which resizing stops |
onPropertyContextMenu Inherited | (args: PropertyGridContextMenuArgs) => void | undefined | CommonPropertyGridProps | Called to show a context menu when properties are right-clicked |
onPropertyEditing Inherited | (args: PropertyEditingArgs, category: PropertyCategory) => void | undefined | CommonPropertyGridProps | Callback for when properties are being edited |
onPropertySelectionChanged Inherited | (property: PropertyRecord) => void | undefined | CommonPropertyGridProps | Callback to property selection |
onPropertyUpdated Inherited | (args: PropertyUpdatedArgs, category: PropertyCategory) => Promise<boolean> | undefined | CommonPropertyGridProps | Callback for when properties are updated |
orientation Inherited | Orientation | undefined | CommonPropertyGridProps | Grid orientation. |
propertyValueRendererManager Inherited | PropertyValueRendererManager | undefined | CommonPropertyGridProps | Custom property value renderer manager |
style Inherited | React.CSSProperties | undefined | CommonPropertyGridProps | Custom CSS style properties |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.