EnumPropertyEditor Class

Enum Property Button Group Editor registered for the "enum" type name. It uses the EnumEditor React component.

Extends

Methods

Name Description
constructor(): EnumPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void Inherited PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  

Properties

Name Type Description
containerHandlesEnter Accessor ReadOnly boolean    
containerStopsKeydownPropagation Accessor ReadOnly boolean    
reactNode Accessor ReadOnly React.ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesBlur Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesEscape Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesTab Accessor Inherited ReadOnly boolean PropertyEditorBase  
customDataController Inherited undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 30 January, 2025