HitDetail Class
A HitDetail stores the result when locating geometry displayed in a view. It holds an approximate location on an element (or decoration) from a pick.
Extended by
Methods
Name | Description | |
---|---|---|
clone(): HitDetail | Create a deep copy of this HitDetail | |
draw(_context: DecorateContext): void | Draw this HitDetail as a Decoration. | |
getHitType(): HitDetailType | Get the type of HitDetail. | |
getPoint(): Point3d | Get the hit point for this HitDetail. | |
getToolTip(): Promise<string | HTMLElement> | Get the tooltip content for this HitDetail. | |
isSameHit(otherHit?: HitDetail): boolean | Determine if this HitPoint is from the same source as another HitDetail. |
Properties
Name | Type | Description | |
---|---|---|---|
distFraction Accessor ReadOnly | number | The distance in view coordinates between the hit and the near plane. | |
distXY Accessor ReadOnly | number | The xy distance to the hit in view coordinates. | |
geometryClass Accessor ReadOnly | undefined | GeometryClass | The class of the hit geometry. | |
hitPoint Accessor ReadOnly | Point3d | The approximate location in world coordinates on the geometry identified by this HitDetail. | |
hitSource Accessor ReadOnly | HitSource | The procedure that requested the locate operation. | |
iModel Accessor ReadOnly | IModelConnection | The IModelConnection from which the hit originated. | |
isElementHit Accessor ReadOnly | boolean | Return whether sourceId is for a persistent element and not a pickable decoration. | |
isExternalIModelHit Accessor ReadOnly | boolean | Returns true if this hit originated from an IModelConnection other than the one associated with the Viewport. | |
isMapHit Accessor ReadOnly | boolean | ||
isModelHit Accessor ReadOnly | boolean | ||
modelId Accessor ReadOnly | undefined | string | The Id of the ModelState from which the hit originated. | |
path Accessor ReadOnly | undefined | HitPath | Describes the path by which the hit was located through a series of attached views. | |
priority Accessor ReadOnly | HitPriority | The hit geometry priority/classification. | |
sourceId Accessor ReadOnly | string | The source of the geometry. | |
subCategoryId Accessor ReadOnly | undefined | string | The SubCategory to which the hit geometry belongs. | |
testPoint Accessor ReadOnly | Point3d | The point in world coordinates that was used as the initial locate point. | |
viewAttachment Accessor ReadOnly | undefined | ViewAttachmentHitInfo | Information about the ViewAttachment within which the hit geometry resides, if any. | |
viewport Accessor ReadOnly | ScreenViewport | The viewport in which the locate operation was performed. |
Defined in
- core/frontend/src/HitDetail.ts Line 200
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.