BeTouchEvent Class

A ButtonEvent generated by touch input.

Extends

Implements

Methods

Name Description
constructor(props: BeTouchEventProps): BeTouchEvent    
setFrom(src: BeTouchEvent): this Copy the values from another BeButtonEvent into this BeButtonEvent  
findTouchById(list: TouchList, id: number): undefined | Touch Static    
getTouchListCentroid(list: TouchList, vp: ScreenViewport): undefined | Point2d Static    
getTouchPosition(touch: Touch, vp: ScreenViewport): Point2d Static    

Inherited methods

Name Inherited from Description
clone(): this Inherited BeButtonEvent Make a copy of this BeButtonEvent.
init(props: BeButtonEventProps): void Inherited BeButtonEvent Initialize the values of this BeButtonEvent.
invalidate(): void Inherited BeButtonEvent Mark this BeButtonEvent as invalid.

Properties

Name Type Description
isDoubleTap Accessor ReadOnly boolean    
isSingleTap Accessor ReadOnly boolean    
isSingleTouch Accessor ReadOnly boolean    
isTwoFingerTap Accessor ReadOnly boolean    
isTwoFingerTouch Accessor ReadOnly boolean    
tapCount number    
touchCount Accessor ReadOnly number    
touchEvent TouchEvent    

Inherited properties

Name Type Inherited from Description
button Inherited BeButton BeButtonEvent The mouse button that created this event.
coordsFrom Inherited CoordSource BeButtonEvent How the coordinate values were generated (either from an action by the user or from a program.)
inputSource Inherited InputSource BeButtonEvent Whether this event came from a pointing device (e.g.
isAltKey Accessor Inherited ReadOnly boolean BeButtonEvent Determine whether the alt key was pressed
isControlKey Accessor Inherited ReadOnly boolean BeButtonEvent Determine whether the control key was pressed
isDoubleClick Inherited boolean BeButtonEvent If true, this is the second down in a rapid double-click of the same button.
isDown Inherited boolean BeButtonEvent If true, this event was generated from a mouse-down transition, false from a button-up transition.
isDragging Inherited boolean BeButtonEvent If true, this event was created by pressing, holding, and then moving a mouse button.
isShiftKey Accessor Inherited ReadOnly boolean BeButtonEvent Determine whether the shift key was pressed
isValid Accessor Inherited ReadOnly boolean BeButtonEvent Determine whether this BeButtonEvent has valid data.
keyModifiers Inherited BeModifierKeys BeButtonEvent The keyboard modifiers that were pressed when the event was generated.
point Accessor Inherited Point3d BeButtonEvent The point for this event, in world coordinates.
rawPoint Accessor Inherited Point3d BeButtonEvent The raw (unadjusted) point for this event, in world coordinates.
viewPoint Accessor Inherited Point3d BeButtonEvent The point, in screen coordinates for this event.
viewport Inherited ScreenViewport | undefined BeButtonEvent The ScreenViewport from which this BeButtonEvent was generated.

Defined in

Last Updated: 21 November, 2024