DynamicsContext Class
Provides context for an InteractiveTool to display decorations representing its current state.
@see onDynamicFrame
Extends
Methods
Name | Description | |
---|---|---|
constructor(vp: Viewport, frustum?: Frustum): DynamicsContext | ||
addGraphic(graphic: RenderGraphic): void | Add a graphic to the list of dynamic graphics to be drawn in this context's Viewport. | |
createGraphic(options: Omit<ViewportGraphicBuilderOptions, "viewport">): GraphicBuilder | Create a builder for producing a RenderGraphic appropriate for rendering within this context's Viewport. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
createBranch(branch: GraphicBranch, location: Transform): RenderGraphic Inherited | RenderContext | Create a RenderGraphic which groups a set of graphics into a node in a scene graph, applying to each a transform and optional clip volume and symbology overrides. |
createGraphicBranch(branch: GraphicBranch, location: Transform, opts?: GraphicBranchOptions): RenderGraphic Inherited | RenderContext | Create a graphic from a GraphicBranch. |
createSceneGraphicBuilder(transform?: Transform): GraphicBuilder Inherited | RenderContext | Create a builder for creating a GraphicType.Scene RenderGraphic for rendering within this context's Viewport. |
getPixelSizeAtPoint(inPoint?: Point3d): number Inherited | RenderContext | Given a point in world coordinates, determine approximately how many pixels it occupies on screen based on this context's frustum. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
frustum Readonly Inherited | Frustum | RenderContext | Frustum extracted from the context's Viewport. |
frustumPlanes Readonly Inherited | FrustumPlanes | RenderContext | Frustum planes extracted from the context's Viewport. |
renderSystem Accessor Inherited ReadOnly | RenderSystem | RenderContext | The RenderSystem being used to produce graphics for this context. |
viewFlags Readonly Inherited | ViewFlags | RenderContext | ViewFlags extracted from the context's Viewport. |
viewport Accessor Inherited ReadOnly | Viewport | RenderContext | The Viewport associated with this context. |
Defined in
- core/frontend/src/ViewContext.ts Line 110
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.