RenderGraphic Class
Abstract representation of an object which can be rendered by a RenderSystem. Two broad classes of graphics exist:
- "Scene" graphics generated on the back-end to represent the contents of the models displayed in a Viewport; and
- Decorations created on the front-end to be rendered along with the scene. The latter are produced using a GraphicBuilder.
Extended by
- MockRender.Graphic
- RenderGraphicOwner
Implements
Methods
Name | Description | |
---|---|---|
constructor(): RenderGraphic | ||
dispose(): void Abstract | Disposes of any resources owned by this object. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.