EditTools Namespace
Interface
Type alias
Name |
Description |
EditTools.BusyRetry |
handler for retries when an EditTool attempts to start but a backend command is busy and can't finish its work. |
Defined in
EditTools Class
Supports PrimitiveTool and InputCollector sub-classes.
Methods
Name |
Description |
|
constructor(): EditTools |
|
|
initialize(): Promise<void> Static |
Call this before using the package (e.g., before attempting to use any of its tools.) |
|
registerProjectLocationTools(): void Static |
Can be called after initialize to register tools for changing project extents and geolocation. |
|
startCommand<T>(startArg: EditTools.StartArgs, ...cmdArgs: any[]): Promise<T> Static |
|
|
Properties
Name |
Type |
Description |
|
busyRetry Static |
EditTools.BusyRetry | undefined |
|
|
namespace Static Readonly |
"Editor" |
|
|
tools Static Readonly |
"Editor:tools." |
|
|
Defined in
Last Updated: 21 November, 2024