CreateElementWithDynamicsTool Class

Placement tool base class for creating new elements that use dynamics to show intermediate results.

@note To trigger an element to be inserted on onDataButtonDown, ensure isComplete returns true

Extends

Methods

Name Description
constructor(..._args: any[]): CreateElementWithDynamicsTool    
acceptPoint(ev: BeButtonEvent): Promise<boolean> Protected Called by onDataButtonDown.  
cancelPoint(_ev: BeButtonEvent): Promise<boolean> Protected Called by onResetButtonUp.  
clearGraphics(): void Protected    
createElement(): Promise<void> Protected Insert new element and call saveChanges  
createGraphics(ev: BeButtonEvent): Promise<void> Protected This method is intended to update the dynamic graphics displayed by the tool.  
doCreateElement(_props: GeometricElementProps): Promise<void> Protected Creates a new element in the iModel by interfacing with the core/editor backend.  
getElementProps(placement: PlacementProps): undefined | GeometricElementProps Protected Abstract    
getGeometryProps(placement: PlacementProps): undefined | JsonGeometryStream | FlatBufferGeometryStream Protected Abstract    
getPlacementProps(): undefined | PlacementProps Protected Abstract    
onCleanup(): Promise<void> Invoked when the tool becomes no longer active, to perform additional cleanup logic  
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Invoked when the data button is pressed.  
onDynamicFrame(_ev: BeButtonEvent, context: DynamicsContext): void Called to allow Tool to display dynamic elements.  
onMouseMotion(ev: BeButtonEvent): Promise<void> Invoked when the cursor is moving  
onResetButtonUp(ev: BeButtonEvent): Promise<EventHandled> Invoked when the reset button is released.  
setupAccuDraw(): void Protected Intended to be used to setupAccuSnap.  
setupAndPromptForNextAction(): void Protected Setup auto-locate, AccuSnap, AccuDraw, and supply tool assistance.  
updateDynamicData(ev: BeButtonEvent): Promise<boolean> Protected This function does not handle updating data itself, instead, it directly calls updateElementData to handle that.  
updateElementData(_ev: BeButtonEvent, _isDynamics: boolean): Promise<void> Protected This method is intended to update information related to the element.  

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited CreateElementTool Used to receive property changes from UI.
autoLockTarget(): void Inherited CreateElementTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void Inherited CreateElementTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited CreateElementTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited CreateElementTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited CreateElementTool Helper method for responding to a tool setting property value change by updating saved settings.
decorate(_context: DecorateContext): void Inherited CreateElementTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited CreateElementTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited CreateElementTool Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited CreateElementTool  
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited CreateElementTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited CreateElementTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited CreateElementTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string Inherited CreateElementTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited CreateElementTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited CreateElementTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited CreateElementTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited CreateElementTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Inherited CreateElementTool Determine whether the supplied Viewport is compatible with this tool.
isComplete(_ev: BeButtonEvent): boolean Protected Inherited CreateElementTool Whether tool is ready to insert the new element.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited CreateElementTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited CreateElementTool Invoked when the data button is released.
onInstall(): Promise<boolean> Inherited CreateElementTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited CreateElementTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited CreateElementTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited CreateElementTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited CreateElementTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited CreateElementTool Invoked when the button is released after onMouseStartDrag.
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited CreateElementTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited CreateElementTool Invoked when the mouse wheel moves.
onPostInstall(): Promise<void> Inherited CreateElementTool Setup initial tool state, prompts, etc.
onRedoPreviousStep(): Promise<boolean> Inherited CreateElementTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> Inherited CreateElementTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited CreateElementTool Invoked when the reset button is pressed.
onRestartTool(): Promise<void> Abstract Inherited CreateElementTool Called when an external event may invalidate the current tool's state.
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited CreateElementTool Called when active view changes.
onSuspend(): Promise<void> Inherited CreateElementTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited CreateElementTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited CreateElementTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited CreateElementTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited CreateElementTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited CreateElementTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited CreateElementTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited CreateElementTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> Inherited CreateElementTool Called to reverse to a previous tool state (ex.
onUnsuspend(): Promise<void> Inherited CreateElementTool Restore tool assistance after no longer being suspended by either a ViewTool or InputCollector.
parseAndRun(..._args: string[]): Promise<boolean> Inherited CreateElementTool Run this instance of a tool using a series of string arguments.
processDataButton(ev: BeButtonEvent): Promise<EventHandled> Protected Inherited CreateElementTool Orchestrates advancing the internal state of the tool on a data button event.
provideToolAssistance(mainInstrText?: string, additionalInstr?: ToolAssistanceInstruction[]): void Protected Inherited CreateElementTool Sub-classes should override to provide tool specific instructions.
reloadToolSettingsProperties(): void Inherited CreateElementTool Called by tool to inform UI to reload ToolSettings with new set of properties.
requireWriteableTarget(): boolean Inherited CreateElementTool Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.
run(..._args: any[]): Promise<boolean> Inherited CreateElementTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> Inherited CreateElementTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited CreateElementTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited CreateElementTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited CreateElementTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited CreateElementTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
_graphicsProvider Protected DynamicGraphicsProvider | undefined    
wantAccuSnap Accessor Protected ReadOnly boolean Whether setupAndPromptForNextAction should call AccuSnap.enableSnap for current tool phase.  
wantDynamics Accessor Protected ReadOnly boolean Whether to automatically start element dynamics on button event.  

Inherited properties

Name Type Inherited from Description
briefcase Accessor Inherited ReadOnly undefined | BriefcaseConnection CreateElementTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase.
description Accessor Inherited ReadOnly string CreateElementTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string CreateElementTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string CreateElementTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string CreateElementTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string CreateElementTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean CreateElementTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string CreateElementTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string CreateElementTool The icon for this Tool.
iModel Accessor Inherited ReadOnly IModelConnection CreateElementTool Get the iModel on which this tool operates.
isControlDown Accessor Inherited ReadOnly boolean CreateElementTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean CreateElementTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string CreateElementTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string CreateElementTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly undefined | number CreateElementTool The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number CreateElementTool The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string CreateElementTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean CreateElementTool Used to avoid sending tools up events for which they did not receive the down event.
targetCategory Accessor Inherited ReadOnly string CreateElementTool  
targetIsLocked Inherited boolean CreateElementTool  
targetModelId Accessor Inherited ReadOnly string CreateElementTool  
targetView Inherited Viewport | undefined CreateElementTool The viewport within which the tool operates.
toolId Accessor Inherited ReadOnly string CreateElementTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolId Static Inherited string CreateElementTool The unique string that identifies this tool.

Defined in

Last Updated: 21 November, 2024