DynamicGraphicsProvider Class
A class for creating and managing a RenderGraphic for the purpose of interactive tool dynamics.
Methods
Name | Description | |
---|---|---|
constructor(iModel: IModelConnection, prefix: string): DynamicGraphicsProvider | ||
addGraphic(context: DynamicsContext, transform?: Transform): void | ||
cleanupGraphic(): void | Call to dispose of RenderGraphic held by RenderGraphicOwner. | |
createGraphic(categoryId: string, placement: PlacementProps, geometry: JsonGeometryStream | FlatBufferGeometryStream): Promise<boolean> | Call to request a RenderGraphic for the supplied geometry and placement. | |
createGraphicAndUpdateDynamics(ev: BeButtonEvent, categoryId: string, placement: PlacementProps, geometry: JsonGeometryStream | FlatBufferGeometryStream): void | Call to request a RenderGraphic for the supplied geometry and trigger a dynamic update upon fulfillment. |
Properties
Name | Type | Description | |
---|---|---|---|
chordTolerance | number | Chord tolerance to use to stroke the element's geometry in meters | |
elementId | string | undefined | Optional element id generated graphics will be associated to | |
graphic | RenderGraphicOwner | undefined | ||
iModel Readonly | IModelConnection | ||
modelId | string | undefined | Optional model id generated graphics will be associated to | |
prefix Readonly | string |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.