RotationalSweep Class

A RotationalSweep is

  • A planar contour (any Loop, Path, or parityRegion).
  • An axis vector.
    • The planar contour is expected to be in the plane of the axis vector.
    • The contour may have points and/or lines that are on the axis, but otherwise is entirely on one side of the axis.
  • A sweep angle.

Extends

Methods

Name Description
clone(): RotationalSweep Return a deep clone  
cloneAxisRay(): Ray3d Return clone of (not reference to) the axis vector.  
cloneTransformed(transform: Transform): undefined | RotationalSweep Return a transformed clone.  
constantVSection(vFraction: number): undefined | CurveCollection Return the curves of a constant-v section of the solid.  
dispatchToGeometryHandler(handler: GeometryHandler): any Dispatch to strongly typed handler handler.handleRotationalSweep(this).  
extendRange(range: Range3d, transform?: Transform): void Extend range using sampled points on the surface.  
getConstructiveFrame(): undefined | Transform Return a coordinate frame (right handed unit vectors).  
getCurves(): CurveCollection Return (REFERENCE TO) the swept curves.  
getFractionalRotationTransform(vFraction: number, result?: Transform): Transform Return a transform that rotates around the rotational axis by a fraction of the total sweep.  
getSweep(): Angle Return the sweep angle.  
getSweepContourRef(): SweepContour Return (REFERENCE TO) the swept curves with containing plane markup.  
isAlmostEqual(other: GeometryQuery): boolean Test for same axis, capping, and swept geometry.  
isSameGeometryClass(other: any): boolean Test if other is a RotationalSweep  
tryTransformInPlace(transform: Transform): boolean Transform the contour and axis.  
create(contour: AnyCurve, axis: Ray3d, sweepAngle: Angle, capped: boolean): undefined | RotationalSweep Static Create a rotational sweep.  

Inherited methods

Name Inherited from Description
range(transform?: Transform, result?: Range3d): Range3d Inherited SolidPrimitive Return the range of the entire GeometryQuery tree.
tryTranslateInPlace(dx: number, dy: number0.0, dz: number0.0): boolean Inherited SolidPrimitive Try to move the geometry by dx,dy,dz.
areAlmostEqual(a: GeometryQuery, b: GeometryQuery): boolean Static Inherited SolidPrimitive Apply instance method isAlmostEqual if both are defined.

Properties

Name Type Description
isClosedVolume Accessor ReadOnly boolean Specify if the sweep forms a closed volume.  
solidPrimitiveType Readonly "rotationalSweep" String name for schema properties  

Inherited properties

Name Type Inherited from Description
_capped Protected Inherited boolean SolidPrimitive Flag indicating whether cap region is considered closed (i.e.
capped Accessor Inherited boolean SolidPrimitive Whether this is a capped solid.
children Accessor Inherited ReadOnly undefined | GeometryQuery[] SolidPrimitive Return GeometryQuery children for recursive queries.
* leaf classes do not need to implement.
geometryCategory Readonly Inherited "solid" SolidPrimitive String name for schema properties.

Defined in

Last Updated: 26 April, 2025