GraphicDescriptionContext Interface
Context holding resources like transient Ids, textures, and materials that were allocated on a Worker by a WorkerGraphicDescriptionContext for use in GraphicDescriptions. This context must be supplied to createGraphicFromDescription when converting a GraphicDescription to a RenderGraphic.
@see resolveGraphicDescriptionContext to obtain an implementation of this type.
Methods
Name | Description | |
---|---|---|
remapTransientLocalId(sourceLocalId: number): number | A function that remaps the local Id portion of an Id64String allocated by transientIds, to that of the corresponding |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.