WorkerGraphicDescriptionContext Namespace
Function
Name | Description |
---|---|
WorkerGraphicDescriptionContext.fromProps | Instantiate a context from its opaque representation. |
Defined in
WorkerGraphicDescriptionContext Interface
Context allocated on a Worker to enable it to create GraphicDescriptions. When the Worker returns one or more GraphicDescriptions to the main thread, it should also return this context as a GraphicDescriptionContextProps.
@see fromProps to instantiate this type.
Methods
Name | Description | |
---|---|---|
createGradientTexture(gradient: Gradient.Symb): RenderTexture | Create a texture from a gradient. | |
createMaterial(params: MaterialParams): RenderMaterial | Create a RenderMaterial. | |
createTexture(params: WorkerTextureParams): RenderTexture | Create a texture. | |
toProps(transferables: Set<Transferable>): GraphicDescriptionContextProps | Converts this context to a representation that can be passed back to the main thread. |
Properties
Name | Type | Description | |
---|---|---|---|
transientIds Readonly | TransientIdSequence | A "fork" of the iModel's transient Id sequence obtained from the main thread. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.