CommonItemProps Interface
Definition that specifies properties shared between many ConfigurableUi components.
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | any | undefined | can be used by application to store miscellaneous data. | |
badgeType | BadgeType | undefined | Badge to be overlaid on the item. | |
description | string | ConditionalStringValue | if set, it is used to explicitly set the description shown by components that support a description. | |
icon | string | ConditionalStringValue | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. | |
internalData Readonly | Map<string, any> | undefined | optional data to be used by item implementor. | |
isActive | boolean | undefined | if set, component will be considered "active" an will display an "active stripe" - defaults to false | |
isDisabled | boolean | ConditionalBooleanValue | if true component will be disabled - defaults to false | |
isHidden | boolean | ConditionalBooleanValue | if true component will be hidden - defaults to false | |
isPressed | boolean | undefined | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. | |
label | string | ConditionalStringValue | if set, it is used to explicitly set the label shown by a component. | |
tooltip | string | ConditionalStringValue | used to explicitly set the tooltip shown by a component. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.