UiError Class

Deprecated  in 4.3. Use Bentley.BentleyError instead.

iTwin.js UI UiError class is a subclass of BentleyError. Errors are logged.

Extends

Methods

Name Description
constructor(category: string, message: string, errorNumber: numberBentleyStatus.ERROR, getMetaData?: GetMetaDataFunction): UiError Constructs UiError using BentleyError.  

Inherited methods

Name Inherited from Description
_initName(): string Protected Inherited BentleyError This function returns the name of each error status.
BentleyError get the meta data associated with this BentleyError, if any.
getErrorKey(errorNumber: number): string Static Inherited BentleyError This function returns the name of each error status.
getErrorMessage(error: unknown): string Static Inherited BentleyError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
BentleyError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static Inherited BentleyError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static Inherited BentleyError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
BentleyError get the metadata object associated with an ExceptionMetaData, if any.
isError<T extends LegacyITwinErrorWithNumber>(error: unknown, errorNumber?: number): error is T Static Inherited BentleyError Determine if an error object implements the LegacyITwinErrorWithNumber interface.

Properties

Name Type Description
category string    

Inherited properties

Name Type Inherited from Description
errorNumber Inherited number BentleyError  
boolean BentleyError Returns true if this BentleyError includes (optional) metadata.
iTwinErrorId Accessor Inherited ReadOnly { key: string, scope: string } BentleyError supply the value for iTwinErrorId
iTwinErrorScope Static Readonly Inherited "bentley-error" BentleyError  
undefined | object BentleyError value for logging metadata

Defined in

Last Updated: 03 April, 2025