UiSyncEvent Class

Deprecated  in 4.2.x Use UiSyncEvent from @itwin/appui-react.

UiSync Event class.

Extends

Methods

Name Description
constructor(): UiSyncEvent    

Inherited methods

Name Inherited from Description
addListener(listener: (args: UiSyncEventArgs) => void, scope?: any): () => void Inherited BeUiEvent Registers a Listener to be executed whenever this event is raised.
addOnce(listener: (args: UiSyncEventArgs) => void, scope?: any): () => void Inherited BeUiEvent Registers a callback function to be executed only once when the event is raised.
clear(): void Inherited BeUiEvent Clear all Listeners from this BeEvent.
emit(args: UiSyncEventArgs): void Inherited BeUiEvent Raises event with single strongly typed argument.
has(listener: (args: UiSyncEventArgs) => void, scope?: any): boolean Inherited BeUiEvent Determine whether this BeEvent has a specified listener registered.
raiseEvent(...args: [args]): void Inherited BeUiEvent Raises the event by calling each registered listener with the supplied arguments.
removeListener(listener: (args: UiSyncEventArgs) => void, scope?: any): boolean Inherited BeUiEvent Un-register a previously registered listener.

Inherited properties

Name Type Inherited from Description
numberOfListeners Accessor Inherited ReadOnly number BeUiEvent The number of listeners currently subscribed to the event.

Defined in

Last Updated: 21 November, 2024