inlineGeometryParts Method
Attempts to optimize all of the geometry in this iModel by identifying GeometryParts that are referenced by exactly one element's geometry stream. Each such reference is replaced by inserting the part's geometry directly into the element's geometry stream. Then, the no-longer-used geometry part is deleted. This can improve performance when a connector inadvertently creates large numbers of parts that are each only used once.
inlineGeometryParts(): InlineGeometryPartsResult
Returns - InlineGeometryPartsResult
Defined in
- core/backend/src/IModelDb.ts Line 1554
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.