InlineGeometryPartsResult Interface

The output of inlineGeometryParts. If numCandidateParts, numRefsInlined, and [[numPartsDeleted ]] are all the same, the operation was fully successful. Otherwise, some errors occurred inlining and/or deleting one or more parts. A part will not be deleted unless it is first successfully inlined.

Properties

Name Type Description
numCandidateParts number The number of parts that were determined to have exactly one reference, making them candidates for inlining.  
numPartsDeleted number The number of candidate parts that were successfully deleted after inlining.  
numRefsInlined number The number of part references successfully inlined.  

Defined in

Last Updated: 18 January, 2025