SpatialViewDefinition Class
Defines a view of one or more SpatialModels. The list of viewed models is stored by the ModelSelector.
This is how a SpatialViewDefinition selects the elements to display:
SpatialViewDefinition
- ModelSelector
- ModelIds -------> SpatialModels <----------GeometricElement3d.Model
- CategorySelector
- CategoryIds -----> SpatialCategories <----------GeometricElement3d.Category
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: SpatialViewDefinitionProps, iModel: IModelDb): SpatialViewDefinition Protected | ||
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected | Collect the Ids of this entity's references at this level of the class hierarchy. | |
loadModelSelector(): ModelSelector | Load this view's ModelSelector from the IModelDb. | |
toJSON(): SpatialViewDefinitionProps | Obtain the JSON representation of this Entity. | |
createWithCamera(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso, cameraAngle: numberAngle.piOver2Radians): SpatialViewDefinition Static | Create a SpatialViewDefinition with the camera turned on. | |
fromJSON(props: Omit<SpatialViewDefinitionProps, "classFullName">, iModel: IModelDb): SpatialViewDefinition Static | Construct a SpatialViewDefinition from its JSON representation. | |
insertWithCamera(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso, cameraAngle: numberAngle.piOver2Radians): string Static | Insert an SpatialViewDefinition with the camera turned on. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited | ViewDefinition3d | Collect the Ids of this element's references at this level of the class hierarchy. |
delete(): void Inherited | ViewDefinition3d | Delete this Element from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | ViewDefinition3d | Call a function for each property of this Entity. |
getAuxiliaryCoordinateSystemId(): string Inherited | ViewDefinition3d | The Id of the AuxiliaryCoordinateSystem for this ViewDefinition, or an invalid Id if no ACS is defined. |
getClassMetaData(): undefined | EntityMetaData Inherited | ViewDefinition3d | Get the class metadata for this element. |
getDisplayLabel(): string Inherited | ViewDefinition3d | Get a display label for this Element. |
getJsonProperty(nameSpace: string): any Inherited | ViewDefinition3d | Get a JSON property of this element, by namespace |
getPredecessorIds(): Id64Set Inherited | ViewDefinition3d | Get the Ids of this element's references. |
getReferenceIds(): EntityReferenceSet Inherited | ViewDefinition3d | Get the set of this entity's entity references, EntityReferenceSet. |
ViewDefinition3d | Get a list of HTML strings that describe this Element for the tooltip. | |
getUserProperties(namespace: string): any Inherited | ViewDefinition3d | Get a set of JSON user properties by namespace |
insert(): string Inherited | ViewDefinition3d | Insert this Element into the iModel. |
isDrawingView(): this is DrawingViewDefinition Inherited | ViewDefinition3d | Type guard for 'instanceof DrawingViewDefinition' |
isSpatialView(): this is SpatialViewDefinition Inherited | ViewDefinition3d | Type guard for instanceof SpatialViewDefinition |
isView2d(): this is ViewDefinition2d Inherited | ViewDefinition3d | Type guard for 'instanceof ViewDefinition2d` |
isView3d(): this is ViewDefinition3d Inherited | ViewDefinition3d | Type guard for instanceof ViewDefinition3d |
loadCategorySelector(): CategorySelector Inherited | ViewDefinition3d | Load this view's CategorySelector from the IModelDb. |
loadDisplayStyle(): DisplayStyle Inherited | ViewDefinition3d | Load this view's DisplayStyle from the IModelDb. |
loadDisplayStyle3d(): DisplayStyle3d Inherited | ViewDefinition3d | Load this view's DisplayStyle3d from the IModelDb. |
removeUserProperties(nameSpace: string): void Inherited | ViewDefinition3d | Remove a set of JSON user properties, specified by namespace, from this Element |
setAuxiliaryCoordinateSystemId(acsId: string): void Inherited | ViewDefinition3d | Set or clear the AuxiliaryCoordinateSystem for this ViewDefinition. |
setJsonProperty(nameSpace: string, value: any): void Inherited | ViewDefinition3d | |
setUserProperties(nameSpace: string, value: any): void Inherited | ViewDefinition3d | Change a set of user JSON properties of this Element by namespace. |
update(): void Inherited | ViewDefinition3d | Update this Element in the iModel. |
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Inherited | ViewDefinition3d | Create a Code for a ViewDefinition given a name that is meant to be unique within the scope of the specified DefinitionModel. |
is(otherClass: ): boolean Static Inherited | ViewDefinition3d | return whether this Entity class is a subclass of another Entity class |
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited | ViewDefinition3d | Called on an element in a graph after all of its inputs have been processed and before its outputs are processed. |
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited | ViewDefinition3d | Called when a root element in a subgraph is changed and before its outputs are processed. |
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited | ViewDefinition3d | Called when an existing element is about to be updated so that an instance of this class will become its new parent. |
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after an existing element has been updated so that an instance of this class is its new parent. |
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called when an element with an instance of this class as its parent is about to be deleted. |
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after an element with an instance of this class as its parent was successfully deleted. |
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called when an element with an instance of this class as its parent is about to be updated change to a different parent. |
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after an element with an instance of this class as its previous parent was updated to have a new parent. |
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited | ViewDefinition3d | Called when a new element with an instance of this class as its parent is about to be inserted. |
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after a new element with an instance of this class as its parent was inserted. |
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited | ViewDefinition3d | Called when an element with an instance of this class as its parent is about to be updated. |
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after an element with an instance of this the class as its parent was updated. |
onCloned(context: IModelElementCloneContext, sourceElementProps: ViewDefinitionProps, targetElementProps: ViewDefinitionProps): void Protected Static Inherited | ViewDefinition3d | |
onDelete(arg: OnElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called before an Element is deleted. |
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after an Element was deleted. |
onInsert(arg: OnElementPropsArg): void Protected Static Inherited | ViewDefinition3d | Called before a new Element is inserted. |
onInserted(arg: OnElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after a new Element was inserted. |
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited | ViewDefinition3d | Called when a sub-model of an instance of this class is being deleted. |
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited | ViewDefinition3d | Called after a sub-model of an instance of this class was deleted. |
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited | ViewDefinition3d | Called when an instance of this class is being sub-modeled by a new Model. |
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited | ViewDefinition3d | Called after an instance of this class was sub-modeled by a new Model. |
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited | ViewDefinition3d | Called before an Element is updated. |
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited | ViewDefinition3d | Called after an Element was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. | |
modelSelectorId | string | The Id of the ModelSelector for this SpatialViewDefinition. | |
requiredReferenceKeys Static Readonly | ReadonlyArray |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
angles Inherited | YawPitchRollAngles | ViewDefinition3d | Rotation from world coordinates to view coordinates. |
camera Inherited | Camera | ViewDefinition3d | The camera used for this view, if cameraOn is true. |
cameraOn Inherited | boolean | ViewDefinition3d | If true, camera is used. |
categorySelectorId Inherited | string | ViewDefinition3d | The element Id of the CategorySelector for this ViewDefinition |
classFullName Accessor Inherited ReadOnly | string | ViewDefinition3d | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | ViewDefinition3d | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | ViewDefinition3d | The name of the BIS class associated with this class. |
code Inherited | Code | ViewDefinition3d | The Code for this element |
details Accessor Inherited ReadOnly | ViewDetails3d | ViewDefinition3d | Provides access to optional detail settings for this view. |
displayStyleId Inherited | string | ViewDefinition3d | The element Id of the DisplayStyle for this ViewDefinition |
extents Inherited | Vector3d | ViewDefinition3d | The extent (size) of the view frustum, in meters, along its x,y,z axes. |
federationGuid Inherited | string | undefined | ViewDefinition3d | A FederationGuid assigned to this element by some other federated database |
id Inherited | string | ViewDefinition3d | The Id of this Entity. |
iModel Inherited | IModelDb | ViewDefinition3d | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | ViewDefinition3d | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isPrivate Inherited | boolean | ViewDefinition3d | If true, don't show this DefinitionElement in user interface lists. |
jsonProperties Readonly Inherited | { T } | ViewDefinition3d | Optional json properties of this element. |
model Readonly Inherited | string | ViewDefinition3d | The ModelId of the Model containing this element |
origin Inherited | Point3d | ViewDefinition3d | The lower left back corner of the view frustum. |
parent Inherited | RelatedElement | undefined | ViewDefinition3d | The parent element, if present, of this element. |
schema Static Inherited | ViewDefinition3d | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | ViewDefinition3d | The name of the BIS Schema that defines this class |
userLabel Inherited | string | undefined | ViewDefinition3d | A user-assigned label for this element. |
Defined in
- core/backend/src/ViewDefinition.ts Line 326
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.