OnChildElementPropsArg Interface
Argument for the Element.onChildXxx
static methods that supply the properties of the child Element to be inserted or updated.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
childProps | Readonly<ElementProps> | The new properties of the child Element for this method. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
iModel Inherited | IModelDb | OnChildElementArg | The iModel for the Element affected by this method. |
parentId Inherited | string | OnChildElementArg |
Defined in
- core/backend/src/Element.ts Line 66
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.