ElementProps Interface
Properties of an Element
Extends
Properties
Name | Type | Description | |
---|---|---|---|
code | CodeProps | The Code for this element | |
federationGuid | string | undefined | A FederationGuid assigned to this element. | |
jsonProperties | any | undefined | Optional json properties of this element. | |
model | string | The Id of the Model containing this element | |
parent | RelatedElementProps | undefined | The Parent of this element, if defined. | |
userLabel | string | undefined | A user-assigned label for this element. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id Inherited | string | undefined | EntityProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | EntityProps | A non-existent property used to discriminate between EntityProps and Entity. |
Defined in
- core/common/src/ElementProps.ts Line 36
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.