DisplayStyle3d Class

A DisplayStyle for 3d views. See [how to create a DisplayStyle3d]$(docs/learning/backend/CreateElements.md#DisplayStyle3d).

Extends

Methods

Name Description
constructor(props: DisplayStyle3dProps, iModel: IModelDb): DisplayStyle3d Protected    
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Collect the Ids of this entity's references at this level of the class hierarchy.  
create(iModelDb: IModelDb, definitionModelId: string, name: string, options?: DisplayStyleCreationOptions): DisplayStyle3d Static Create a DisplayStyle3d for use by a ViewDefinition.  
insert(iModelDb: IModelDb, definitionModelId: string, name: string, options?: DisplayStyleCreationOptions): string Static Insert a DisplayStyle3d for use by a ViewDefinition.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited DisplayStyle Collect the Ids of this element's references at this level of the class hierarchy.
delete(): void Inherited DisplayStyle Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited DisplayStyle Call a function for each property of this Entity.
DisplayStyle Get the class metadata for this element.
getDisplayLabel(): string Inherited DisplayStyle Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited DisplayStyle Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited DisplayStyle Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited DisplayStyle Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited DisplayStyle Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited DisplayStyle Get a set of JSON user properties by namespace
insert(): string Inherited DisplayStyle Insert this Element into the iModel.
loadScheduleScript(): undefined | RenderSchedule.ScriptReference Inherited DisplayStyle  
removeUserProperties(nameSpace: string): void Inherited DisplayStyle Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited DisplayStyle  
setUserProperties(nameSpace: string, value: any): void Inherited DisplayStyle Change a set of user JSON properties of this Element by namespace.
toJSON(): DefinitionElementProps Inherited DisplayStyle Obtain the JSON representation of this Entity.
update(): void Inherited DisplayStyle Update this Element in the iModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Inherited DisplayStyle Create a Code for a DisplayStyle given a name that is meant to be unique within the scope of the specified DefinitionModel.
is(otherClass: ): boolean Static Inherited DisplayStyle return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited DisplayStyle Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited DisplayStyle Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited DisplayStyle Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited DisplayStyle Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited DisplayStyle Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited DisplayStyle Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited DisplayStyle Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited DisplayStyle Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited DisplayStyle Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited DisplayStyle Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited DisplayStyle Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited DisplayStyle Called after an element with an instance of this the class as its parent was updated.
onDelete(arg: OnElementIdArg): void Protected Static Inherited DisplayStyle Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited DisplayStyle Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited DisplayStyle Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited DisplayStyle Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited DisplayStyle Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited DisplayStyle Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited DisplayStyle Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited DisplayStyle Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited DisplayStyle Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited DisplayStyle Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
settings Accessor ReadOnly DisplayStyle3dSettings    

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string DisplayStyle Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string DisplayStyle Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string DisplayStyle The name of the BIS class associated with this class.
code Inherited Code DisplayStyle The Code for this element
federationGuid Inherited string | undefined DisplayStyle A FederationGuid assigned to this element by some other federated database
id Inherited string DisplayStyle The Id of this Entity.
iModel Inherited IModelDb DisplayStyle The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" DisplayStyle An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean DisplayStyle If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly Inherited { T } DisplayStyle Optional json properties of this element.
model Readonly Inherited string DisplayStyle The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined DisplayStyle The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray DisplayStyle A required reference is an element that had to be inserted before this element could have been inserted.
schema Static Inherited DisplayStyle The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string DisplayStyle The name of the BIS Schema that defines this class
userLabel Inherited string | undefined DisplayStyle A user-assigned label for this element.

Defined in

Last Updated: 21 November, 2024