DisplayStyle3dProps Interface
JSON representation of a DisplayStyle3d or DisplayStyle3dState.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
jsonProperties | { styles?: DisplayStyle3dSettingsProps } | undefined | Display styles store their settings in a styles property within jsonProperties. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | DisplayStyleProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code Inherited | CodeProps | DisplayStyleProps | The Code for this element |
federationGuid Inherited | string | undefined | DisplayStyleProps | A FederationGuid assigned to this element. |
id Inherited | string | undefined | DisplayStyleProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | DisplayStyleProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate Inherited | boolean | undefined | DisplayStyleProps | |
model Inherited | string | DisplayStyleProps | The Id of the Model containing this element |
parent Inherited | RelatedElementProps | undefined | DisplayStyleProps | The Parent of this element, if defined. |
userLabel Inherited | string | undefined | DisplayStyleProps | A user-assigned label for this element. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.