DisplayStyle3dSettingsProps Interface

JSON representation of DisplayStyle3dSettings associated with a DisplayStyle3dProps.

Extends

Properties

Name Type Description
ao AmbientOcclusion.Props | undefined See ambientOcclusionSettings.  
contours ContourDisplayProps | undefined See contours.  
environment EnvironmentProps | undefined See environment.  
hline HiddenLine.SettingsProps | undefined See hiddenLineSettings.  
lights LightSettingsProps | undefined See DisplayStyle3dSettings.lights.  
planProjections { T } | undefined See planProjections.  
solarShadows SolarShadowSettingsProps | undefined See solarShadows.  
thematic ThematicDisplayProps | undefined See thematic.  

Inherited properties

Name Type Inherited from Description
analysisFraction Inherited number | undefined DisplayStyleSettingsProps See analysisFraction.
analysisStyle Inherited AnalysisStyleProps | undefined DisplayStyleSettingsProps See analysisStyle.
backgroundColor Inherited number | undefined DisplayStyleSettingsProps See backgroundColor.
backgroundMap Inherited PersistentBackgroundMapProps | undefined DisplayStyleSettingsProps See backgroundMap.
clipStyle Inherited ClipStyleProps | undefined DisplayStyleSettingsProps See clipStyle.
contextRealityModels Inherited ContextRealityModelProps[] | undefined DisplayStyleSettingsProps See contextRealityModels.
excludedElements Inherited string | Id64Array DisplayStyleSettingsProps Ids of elements not to be displayed in the view.
mapImagery Inherited MapImageryProps | undefined DisplayStyleSettingsProps See mapImagery.
modelOvr Inherited DisplayStyleModelAppearanceProps[] | undefined DisplayStyleSettingsProps Overrides applied to the appearance of models in the view.
monochromeColor Inherited number | undefined DisplayStyleSettingsProps See monochromeColor.
monochromeMode Inherited MonochromeMode | undefined DisplayStyleSettingsProps See monochromeMode.
planarClipOvr Inherited DisplayStylePlanarClipMaskProps[] | undefined DisplayStyleSettingsProps See planarClipMasks.
realityModelDisplay Inherited DisplayStyleRealityModelDisplayProps[] | undefined DisplayStyleSettingsProps Display settings applied to specific reality models in the view.
renderTimeline Inherited string | undefined DisplayStyleSettingsProps See renderTimeline.
scheduleScript Inherited RenderSchedule.ScriptProps | undefined DisplayStyleSettingsProps See scheduleScriptProps.
subCategoryOvr Inherited DisplayStyleSubCategoryProps[] | undefined DisplayStyleSettingsProps Overrides applied to the appearances of subcategories in the view.
timePoint Inherited number | undefined DisplayStyleSettingsProps See timePoint.
viewflags Inherited ViewFlagProps | undefined DisplayStyleSettingsProps See viewFlags.
whiteOnWhiteReversal Inherited WhiteOnWhiteReversalProps | undefined DisplayStyleSettingsProps See whiteOnWhiteReversal.

Defined in

Last Updated: 21 November, 2024