DisplayStyleSubCategoryProps Interface
Describes the SubCategoryOverrides applied to a SubCategory by a DisplayStyle.
@see DisplayStyleSettingsProps
Extends
Properties
Name | Type | Description | |
---|---|---|---|
subCategory | string | undefined | The Id of the SubCategory whose appearance is to be overridden. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
color Inherited | number | undefined | SubCategoryAppearance.Props | See SubCategoryAppearance.color. |
fill Inherited | number | undefined | SubCategoryAppearance.Props | See fillColor. |
invisible Inherited | boolean | undefined | SubCategoryAppearance.Props | See invisible. |
material Inherited | string | undefined | SubCategoryAppearance.Props | See materialId. |
priority Inherited | number | undefined | SubCategoryAppearance.Props | See priority. |
style Inherited | string | undefined | SubCategoryAppearance.Props | See styleId. |
transp Inherited | number | undefined | SubCategoryAppearance.Props | See transparency. |
transpFill Inherited | number | undefined | SubCategoryAppearance.Props | See fillTransparency. |
weight Inherited | number | undefined | SubCategoryAppearance.Props | See SubCategoryAppearance.weight. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.