ModelessDialogProps Interface
Deprecated in 4.15.0. Props of deprecated ModelessDialog component.
Properties for the ModelessDialog component
Extends
- DialogProps
Properties
Name | Type | Description | |
---|---|---|---|
dialogId | string | ||
movable | boolean | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
alignment | DialogAlignment | undefined | DialogProps | Default alignment of dialog. |
backgroundStyle | React.CSSProperties | undefined | DialogProps | Custom CSS Style for overlay |
buttonCluster | DialogButtonDef[] | undefined | DialogProps | List of DialogButtonDef objects specifying buttons and associated onClick events |
contentClassName | string | undefined | DialogProps | Custom CSS class name for the content |
contentStyle | React.CSSProperties | undefined | DialogProps | Custom CSS Style for the content |
footer | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | DialogProps | Footer to show at bottom of dialog. |
footerStyle | React.CSSProperties | undefined | DialogProps | Custom CSS Style for footer |
header | React.ReactNode | undefined | DialogProps | Override for the header |
height | string | number | DialogProps | Initial height of dialog. |
hideHeader | boolean | undefined | DialogProps | Whether the hide the header. |
inset | boolean | undefined | DialogProps | Indicates whether the content should be inset. |
itemId | string | undefined | DialogProps | Optional unique identifier for item. |
maxHeight | string | number | DialogProps | Maximum height that the dialog may be resized to. |
maxWidth | string | number | DialogProps | Maximum width that the dialog may be resized to. |
minHeight | string | number | DialogProps | Minimum height that the dialog may be resized to. |
minWidth | string | number | DialogProps | Minimum width that the dialog may be resized to. |
modal | boolean | undefined | DialogProps | Whether to show background overlay. |
modelessId | string | undefined | DialogProps | An id for a modeless dialog |
onClose | () => void | undefined | DialogProps | onClick event for X button for dialog |
onEscape | () => void | undefined | DialogProps | 'keyup' event for Esc key |
onModelessPointerDown | (event: React.PointerEvent<Element>, id: string) => void | undefined | DialogProps | Pointer Down event handler when modeless (modal = false) |
onOutsideClick | (event: MouseEvent) => any | undefined | DialogProps | Triggered when a click is triggered outside of this dialog. |
opened | boolean | DialogProps | Indicates whether to show dialog or not |
resizable | boolean | undefined | DialogProps | Indicates whether the user can resize dialog with cursor. |
title | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | DialogProps | Title to show in title bar of dialog |
titleStyle | React.CSSProperties | undefined | DialogProps | Custom CSS Style for title |
trapFocus | boolean | undefined | DialogProps | Indicates whether the focus should be trapped within the dialog. |
width | string | number | DialogProps | Initial width of dialog. |
x | number | undefined | DialogProps | Initial x/left position of dialog in px. |
y | number | undefined | DialogProps | Initial y/top position of dialog in px. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.