FrameworkToolSettings Interface
toolSettings interface
Methods
Name | Description | |
---|---|---|
clearToolSettingsData(): void | clear cached Tool Settings properties. | |
focusIntoToolSettings(): boolean | Sets the focus on the ToolSettings UI element. | |
initializeDataForTool(tool: InteractiveTool): void | Set of data used in Tool Settings for the specified tool. | |
initializeToolSettingsData(toolSettingsProperties: DialogItem[], toolId?: string, toolLabel?: string, toolDescription?: string): boolean | Cache Tool Settings properties |
Properties
Name | Type | Description | |
---|---|---|---|
activeToolDescription Readonly | string | Returns the description of the active tool. | |
activeToolLabel | string | The name of the active tool. | |
onReloadToolSettingsProperties Readonly | UiEvent<void> | ||
onSyncToolSettingsProperties Readonly | SyncToolSettingsPropertiesEvent | Get ToolSettings Properties sync event. | |
toolIdForToolSettings Readonly | string | Gets the Id of the active tool. | |
toolSettingsProperties Readonly | DialogItem[] | Returns the toolSettings properties that can be used to populate the tool settings widget. | |
useDefaultToolSettingsProvider | boolean | Returns true if the Tool Settings are to be auto populated from the toolSettingsProperties. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.