ConfigurableUiContentProps Interface
Deprecated in 4.17.0. Use React.ComponentProps<typeof ConfigurableUiContent>
Properties for ConfigurableUiContent
Extends
Properties
Name | Type | Description | |
---|---|---|---|
animateToolSettings | boolean | undefined | Controls if the tool settings should be animated. | |
appBackstage | React.ReactNode | undefined | React node of the Backstage | |
collapsePanels | boolean | undefined | Controls if the unpinned panels should be collapsed automatically. | |
toolAsToolSettingsLabel | boolean | undefined | Controls if the tool settings label should be set based on activated tool. | |
toolbarOpacity | number | undefined | Describes the opacity of toolbars. | |
viewOverlay | boolean | undefined | Controls if the view overlay should be displayed. | Deprecated |
widgetIcon | boolean | undefined | Controls if the widget icons should be displayed. | |
widgetOpacity | number | undefined | Describes the opacity of widgets. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.