FrameworkKeyboardShortcut Interface
Keyboard Shortcut used to execute an action
Methods
Name | Description | |
---|---|---|
getShortcut(mapKey: string): undefined | FrameworkKeyboardShortcut | Finds a shortcut with a given key in the shortcut's container | |
itemPicked(): void | Called when the ActionButtonItemDef associated with this shortcut is invoked | |
setDescription(v: string | StringGetter | ConditionalStringValue): void | ||
setLabel(v: string | StringGetter | ConditionalStringValue): void | ||
setTooltip(v: string | StringGetter | ConditionalStringValue): void |
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | any | undefined | ||
badgeKind Readonly | BadgeKind | undefined | Specifies the kind of badge, if any, to be overlaid on the item. | |
badgeType | BadgeType | undefined | Deprecated | |
description Readonly | string | ||
iconElement | React.ReactNode | undefined | ||
iconNode Readonly | React.ReactNode | undefined | ||
iconSpec | IconSpec | undefined | Deprecated | |
id Readonly | string | Returns the id for this shortcut | |
isActive | boolean | ||
isAltKeyRequired Readonly | boolean | Gets whether the Alt key required. | |
isCtrlKeyRequired Readonly | boolean | Gets whether the Ctrl key required. | |
isDisabled | boolean | ConditionalBooleanValue | ||
isFunctionKey Readonly | boolean | Gets whether this is a Function key. | |
isHidden | boolean | ConditionalBooleanValue | ||
isPressed | boolean | ||
isShiftKeyRequired Readonly | boolean | Gets whether the Shift key required. | |
isSpecialKey Readonly | boolean | Gets whether this is a Special key. | |
item Readonly | undefined | ActionButtonItemDef | Returns the ActionButtonItemDef associated with this shortcut. | Deprecated |
key Readonly | string | Gets the keyboard key | |
keyMapKey Readonly | string | Returns the shortcut's key map key used as the id | |
label Readonly | string | ||
rawLabel Readonly | string | StringGetter | ConditionalStringValue | ||
shortcutContainer Readonly | FrameworkKeyboardShortcutContainer | Returns the shortcut container | |
tooltip Readonly | string | ||
trayId | undefined |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.