ToolSettingsPopupProps Interface

Props for defining a popup tool settings component

Extends

Properties

Name Type Description
dataProvider DialogLayoutDataProvider    
onCancel OnCancelFunc    
orientation Orientation    
relativePosition RelativePosition    

Inherited properties

Name Type Inherited from Description
el Inherited HTMLElement PopupPropsBase  
id Inherited string PopupPropsBase  
offset Inherited Readonly<WritableXAndY> PopupPropsBase  
pt Inherited Readonly<WritableXAndY> PopupPropsBase  

Defined in

Last Updated: 30 January, 2025