ConfigurableUiActionId Enumeration

Deprecated  in 4.15.0. Use your preferred state management library instead.

Action Ids used by Redux and to send sync UI components. Typically used to refresh visibility or enable state of control. Since these are also used as sync ids they should be in lowercase.

@note This is used by sync UI event APIs.

Members

Name Value Description
AnimateToolSettings  
AutoCollapseUnpinnedPanels  
SetDragInteraction  
SetShowWidgetIcon  
SetSnapMode  
SetTheme  
SetToolbarOpacity  
SetToolPrompt  
SetViewOverlayDisplay  
SetWidgetOpacity  
UseToolAsToolSettingsLabel  

Defined in

Last Updated: 20 November, 2024