StandardFrontstageProps Interface
Props of a StandardFrontstageProvider.
Properties
Name | Type | Description | |
---|---|---|---|
bottomPanelProps | WidgetPanelProps | undefined | Props used to set initial size and state of panel. | |
contentGroupProps | ContentGroupProps | ContentGroupProvider | Definition of available content groups or a function that provides them | |
cornerButton | React.ReactNode | undefined | Specify a corner button. | |
defaultTool | string | undefined | Default tool of the frontstage. | |
hideNavigationAid | boolean | undefined | Set to true if default navigation aid is not desired. |
|
hideStatusBar | boolean | undefined | Set to true if no status bar is needed in stage |
|
hideToolSettings | boolean | undefined | Set to true if no tool setting dock is needed. |
|
id | string | Id of the frontstage. | |
leftPanelProps | WidgetPanelProps | undefined | Props used to set initial size and state of panel. | |
rightPanelProps | WidgetPanelProps | undefined | Props used to set initial size and state of panel. | |
topPanelProps | WidgetPanelProps | undefined | Props used to set initial size and state of panel. | |
usage | string | Usage of the frontstage. | |
version | number | undefined | Version of the frontstage. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.