ToolbarWithOverflowProps Interface
Component that displays toolbar items.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
expandsTo | Direction | undefined | Describes to which direction the popup panels are expanded, also defines the orientation of the toolbar (Top/Bottom will create an horizontal toolbar, Left/Right will create a vertical toolbar). | |
items | ToolbarItem[] | Definitions for items of the toolbar. | |
onItemExecuted | OnItemExecutedFunc | undefined | Optional function to call on any item execution | |
onKeyDown | (e: React.KeyboardEvent<Element>) => void | undefined | Optional function to call on any KeyDown events processed by toolbar | |
overflowExpandsTo | Direction | undefined | Describes to which direction the overflow popup panels are expanded. | |
panelAlignment | ToolbarPanelAlignment | undefined | Describes how expanded panels are aligned. | |
toolbarOpacitySetting | ToolbarOpacitySetting | undefined | Determines whether to use mouse proximity to alter the opacity of the toolbar | |
useDragInteraction | boolean | undefined | Use Drag Interaction to open popups with nest action buttons |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
children | undefined | undefined | NoChildrenProps | |
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.