StagePanelDef Class

A StagePanelDef represents each Stage Panel within a Frontstage.

Extends

Methods

Name Description
constructor(): StagePanelDef Constructor for PanelDef.  

Inherited methods

Name Inherited from Description
addWidgetDef(widgetDef: WidgetDef): void Inherited WidgetHost Adds a WidgetDef to the list of Widgets.
findWidgetDef(id: string): undefined | WidgetDef Inherited WidgetHost Finds a WidgetDef with a given Id.
getSingleWidgetDef(): undefined | WidgetDef Inherited WidgetHost If there is only one Widget in the Panel, gets the single WidgetDef.

Properties

Name Type Description
location Accessor ReadOnly StagePanelLocation Location of panel.  
panelState Accessor StagePanelState Panel state.  
pinned Accessor boolean Indicates whether the panel is pinned.  
resizable Accessor ReadOnly boolean Indicates whether the panel is resizable.  
size Accessor undefined | number Current size of the panel.  
sizeSpec Accessor undefined | StagePanelSizeSpec Current size of the panel  
widgetDefs Accessor ReadOnly ReadonlyArray<WidgetDef> Gets the list of Widgets.  

Inherited properties

Name Type Inherited from Description
widgetCount Accessor Inherited ReadOnly number WidgetHost Gets the number of Widgets.

Defined in

Last Updated: 30 January, 2025