WidgetDef Class
A Widget Definition in the 9-Zone Layout system.
Methods
Name | Description | |
---|---|---|
constructor(): WidgetDef | ||
canOpen(): boolean | ||
expand(): void | Opens the widget and expands it to fill full size of the stage panel. | |
getWidgetControl(type: ConfigurableUiControlType): undefined | WidgetControl | Deprecated | |
onWidgetStateChanged(): void | ||
restoreTransientState(): boolean | Overwrite to restore transient DOM state. | |
saveTransientState(): void | Overwrite to save transient DOM state (i.e. | |
setCanPopout(value: boolean): void | ||
setFloatingContainerId(value: string): void | ||
setLabel(labelSpec: string | StringGetter | ConditionalStringValue): void | Set the label. | |
setTooltip(v: string | StringGetter | ConditionalStringValue): void | Set the tooltip. | |
setWidgetState(newState: WidgetState): void | ||
show(): void | Opens the widget and makes it visible to the user. |
Properties
Name | Type | Description | |
---|---|---|---|
activeState Accessor ReadOnly | WidgetState | ||
allowedPanelTargets Accessor | undefined | ReadonlyArray<StagePanelLocation> | ||
applicationData Accessor ReadOnly | any | ||
badgeKind Accessor ReadOnly | undefined | BadgeKind | ||
badgeType Accessor ReadOnly | undefined | BadgeType | ||
canPopout Accessor ReadOnly | undefined | boolean | ||
classId Accessor ReadOnly | undefined | string | ConfigurableUiControlConstructor | ||
floatingContainerId Accessor ReadOnly | undefined | string | ||
hideWithUiWhenFloating Accessor | boolean | ||
iconSpec Accessor | IconSpec | ||
id Accessor ReadOnly | string | ||
initialConfig Accessor ReadOnly | undefined | WidgetConfig | ||
isActive Accessor ReadOnly | boolean | ||
isFloating Accessor ReadOnly | boolean | ||
isFloatingStateSupported Accessor ReadOnly | boolean | ||
isFloatingStateWindowResizable Accessor ReadOnly | boolean | ||
isStatusBar Accessor ReadOnly | boolean | ||
isToolSettings Accessor ReadOnly | boolean | ||
isVisible Accessor ReadOnly | boolean | ||
label Accessor ReadOnly | string | Get the label string | |
priority Accessor ReadOnly | number | ||
reactNode Accessor | React.ReactNode | ||
state Accessor ReadOnly | WidgetState | ||
stateChanged Accessor ReadOnly | boolean | ||
tooltip Accessor ReadOnly | string | Get the tooltip string | |
widgetControl Accessor ReadOnly | undefined | WidgetControl | ||
widgetType Accessor | WidgetType |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.