WidgetConfig Interface

Configuration from which a widget is created.

Extends

Properties

Name Type Description
labelKey Readonly string | undefined If set, it is used to define a key that is used to look up a localized string.  
tooltipKey Readonly string | undefined If set, it is used to define a key that is used to look up a localized string.  

Inherited properties

Name Type Inherited from Description
allowedPanels Readonly Inherited ReadonlyArray<StagePanelLocation> | undefined Widget Stage panels to which this widget can be docked.
badge Readonly Inherited BadgeType | undefined Widget Specifies the kind of badge, if any, to be rendered.
badgeKind Readonly Inherited BadgeKind | undefined Widget Specifies the kind of badge, if any, to be rendered.
canFloat Readonly Inherited boolean | CanFloatWidgetOptions Widget Set to false to disable floating of a widget.
canPopout Readonly Inherited boolean | undefined Widget Describes if the widget can be popped out to a separate window.
content Readonly Inherited React.ReactNode | undefined Widget Content of the Widget.
defaultState Readonly Inherited WidgetState | undefined Widget Defaults to Floating if widget is not allowed to dock to any panels.
icon Readonly Inherited IconSpec | undefined Widget  
iconNode Readonly Inherited React.ReactNode | undefined Widget Icon to use for the widget.
id Readonly Inherited string Widget  
label Readonly Inherited string | ConditionalStringValue Widget  
layouts Readonly Inherited WidgetLayouts | undefined Widget Describes layout specific configuration of a widget.
priority Readonly Inherited number | undefined Widget  
tooltip Readonly Inherited string | ConditionalStringValue Widget  

Defined in

Last Updated: 30 January, 2025