Widget Interface
Describes the data needed to provide a widget.
Properties
Name | Type | Description | |
---|---|---|---|
allowedPanels Readonly | ReadonlyArray<StagePanelLocation> | undefined | Stage panels to which this widget can be docked. | |
badge Readonly | BadgeType | undefined | Specifies the kind of badge, if any, to be rendered. | Deprecated |
badgeKind Readonly | BadgeKind | undefined | Specifies the kind of badge, if any, to be rendered. | |
canFloat Readonly | boolean | CanFloatWidgetOptions | Set to false to disable floating of a widget. |
|
canPopout Readonly | boolean | undefined | Describes if the widget can be popped out to a separate window. | |
content Readonly | React.ReactNode | undefined | Content of the Widget. | |
defaultState Readonly | WidgetState | undefined | Defaults to Floating if widget is not allowed to dock to any panels. |
|
icon Readonly | IconSpec | undefined | Deprecated | |
iconNode Readonly | React.ReactNode | undefined | Icon to use for the widget. | |
id Readonly | string | ||
label Readonly | string | ConditionalStringValue | ||
layouts Readonly | WidgetLayouts | undefined | Describes layout specific configuration of a widget. | |
priority Readonly | number | undefined | ||
tooltip Readonly | string | ConditionalStringValue |
Defined in
Last Updated: 21 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.