ReactNotifyMessageDetails Class
Describes a message to be displayed to the user and adds support for React components in messages.
Methods
Name | Description | |
---|---|---|
constructor(priority: OutputMessagePriority, briefMessage: MessageType, detailedMessage?: MessageType, msgType: OutputMessageTypeOutputMessageType.Toast, openAlert: OutputMessageAlertOutputMessageAlert.None): ReactNotifyMessageDetails | Constructor | |
setInputFieldTypeDetails(inputField: HTMLElement): void | Set OutputMessageType.InputField message details. | |
setPointerTypeDetails(viewport: HTMLElement, displayPoint: Readonly<WritableXAndY>, relativePosition: RelativePositionRelativePosition.TopRight): void | Set OutputMessageType.Pointer message details. |
Properties
Name | Type | Description | |
---|---|---|---|
MessageType | A short message that conveys the simplest explanation of the issue. | ||
MessageType | undefined | A comprehensive message that explains the issue in detail and potentially offers a solution. | ||
displayPoint Accessor ReadOnly | undefined | Point2d | Point for a Pointer message | |
displayTime Accessor | BeDuration | Amount of time a Toast message is displayed | |
inputField Accessor ReadOnly | undefined | HTMLElement | Anchor input field for an Input Field message | |
msgType | OutputMessageType | The type of message. | |
openAlert | OutputMessageAlert | Whether an alert box should be displayed or not, and if so what kind. | |
priority | OutputMessagePriority | The priority this message should be accorded by the NotificationManager. | |
relativePosition Accessor ReadOnly | RelativePosition | Relative position for a Pointer message | |
viewport Accessor ReadOnly | undefined | HTMLElement | Anchor viewport for a Pointer message |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.