KeyboardShortcutProps Interface
Properties for a Keyboard Shortcut
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | any | undefined | can be used by application to store miscellaneous data. | |
badgeKind | BadgeKind | undefined | Specifies the kind of badge, if any, to be overlaid on the item. | |
badgeType | BadgeType | undefined | Badge to be overlaid on the item. | Deprecated |
description | string | StringGetter | ConditionalStringValue | if set, it is used to explicitly set the description shown by a component. | |
descriptionKey | string | undefined | if set, it is used to define a key that is used to look up a localized string. | |
execute | () => void | undefined | Function to run when the keyboard shortcut is executed. | |
icon | IconSpec | undefined | Abstract icon definition, used when creating itemDef from abstract item (ie. | Deprecated |
iconNode | React.ReactNode | undefined | Icon used for a shortcut. | |
iconSpec | IconSpec | undefined | Deprecated | |
isActive | boolean | undefined | if set, component will be considered "active" an will display an "active stripe" - defaults to false | |
isAltKeyRequired | boolean | undefined | Indicates whether the Alt key required. | |
isCtrlKeyRequired | boolean | undefined | Indicates whether the Ctrl key required. | |
isDisabled | boolean | ConditionalBooleanValue | if true component will be disabled - defaults to false | |
isHidden | boolean | ConditionalBooleanValue | if true component will be hidden - defaults to false | |
isPressed | boolean | undefined | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. | |
isShiftKeyRequired | boolean | undefined | Indicates whether the Shift key required. | |
item | ActionButtonItemDef | undefined | The item to execute when this shortcut is invoked. | Deprecated |
key | string | The key that invokes the shortcut. | |
label | string | StringGetter | ConditionalStringValue | if set, it is used to explicitly set the label shown by a component. | |
labelKey | string | undefined | if set, it is used to define a key that is used to look up a localized string. | |
shortcuts | KeyboardShortcutProps[] | undefined | Nested array of shortcut props. | |
tooltip | string | StringGetter | ConditionalStringValue | used to explicitly set the tooltip shown by a component. | |
tooltipKey | string | undefined | if set, it is used to define a key that is used to look up a localized string. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.