WidgetManager Class
Widget Manager class.
Methods
Name | Description | |
---|---|---|
constructor(): WidgetManager | ||
addWidgetDef(widgetDef: WidgetDef, stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection): boolean | Adds a WidgetDef for use in a Frontstage. | |
getWidgetDefs(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection): undefined | ReadonlyArray<WidgetDef> | Gets WidgetDefs for a Frontstage location. | |
removeWidgetDef(widgetId: string): boolean | Removes a WidgetDef. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.