StatusBarWidgetComposerControl Class
Deprecated in 4.16.0. Use StatusBarComposer component instead.
StatusBarWidgetComposerControl provides status bar to specified Frontstage that allows status bar items to be populated via UiItemsProviders. See StandardStatusbarItemsProvider that can be used to populate this status bar with a common set of status fields.
Extends
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): StatusBarWidgetComposerControl | ||
getReactNode(): React.ReactNode | Gets the React node associated with this StatusBar Widget Control |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getType(): ConfigurableUiControlType Inherited | StatusBarWidgetControl | Gets the type of ConfigurableUiControl, which is 'StatusBarWidget' in this case |
onFrontstageDeactivated(): void Inherited | StatusBarWidgetControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void Inherited | StatusBarWidgetControl | Called when Frontstage is ready. |
onInitialize(): void Inherited | StatusBarWidgetControl | Called to initialize the ConfigurableUiControl. |
onWidgetStateChanged(): void Inherited | StatusBarWidgetControl | Called when widget state changes. |
restoreTransientState(): boolean Inherited | StatusBarWidgetControl | Overwrite to restore transient DOM state. |
saveTransientState(): void Inherited | StatusBarWidgetControl | Overwrite to save transient DOM state (i.e. |
setWidgetState(state: WidgetState): void Inherited | StatusBarWidgetControl | Sets the WidgetState for this control |
Properties
Name | Type | Description | |
---|---|---|---|
controlId Static | string | ||
id Readonly | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected Inherited | any | StatusBarWidgetControl | |
applicationData Accessor Inherited ReadOnly | any | StatusBarWidgetControl | allow options set via appData to be seen by API calls |
classId Accessor Inherited ReadOnly | string | StatusBarWidgetControl | Gets the class Id of configurable element |
controlId Accessor Inherited ReadOnly | string | StatusBarWidgetControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor Inherited ReadOnly | Promise<void> | StatusBarWidgetControl | Returns a promise that resolves when the control is ready for usage. |
name Accessor Inherited ReadOnly | string | StatusBarWidgetControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
reactNode Accessor Inherited | React.ReactNode | StatusBarWidgetControl | The ReactNode associated with this control |
widgetDef Accessor Inherited | WidgetDef | StatusBarWidgetControl | The WidgetDef associated with this control |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.