StandardStatusbarItemsProvider Class

Deprecated  in 4.17.0. Use StandardStatusbarUiItemsProvider instead. Supported frontstages can be specified when registering the provider.

Provide standard status bar fields.

Extends

Methods

Name Description
constructor(providerId: string, _defaultItems?: DefaultStatusbarItems, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardStatusbarItemsProvider    
provideStatusBarItemsInternal(_stageId: string, _stageUsage: string, _stageAppData?: any): StatusBarItem[]    
register(providerId: string, defaultItems?: DefaultStatusbarItems, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardStatusbarItemsProvider Static static function to register the StandardStatusbarItemsProvider  

Inherited methods

Name Inherited from Description
onUnregister(): void Inherited BaseUiItemsProvider Function called when the provider is unregistered.
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): StatusBarItem[] Inherited BaseUiItemsProvider Provides status bar items.
provideToolbarItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): ToolbarItem[] Inherited BaseUiItemsProvider Provides toolbar items.
provideToolbarItemsInternal(_stageId: string, _stageUsage: string, _toolbarUsage: ToolbarUsage, _toolbarOrientation: ToolbarOrientation, _stageAppData?: any): ToolbarItem[] Inherited BaseUiItemsProvider  
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, stageAppData?: any): ReadonlyArray<Widget> Inherited BaseUiItemsProvider Provides widgets.
provideWidgetsInternal(_stageId: string, _stageUsage: string, _location: StagePanelLocation, _section?: StagePanelSection, _stageAppData?: any): Widget[] Inherited BaseUiItemsProvider  
unregister(): void Inherited BaseUiItemsProvider  

Inherited properties

Name Type Inherited from Description
_providerId Protected Inherited string BaseUiItemsProvider  
id Accessor Inherited ReadOnly string BaseUiItemsProvider Id of provider.
isSupportedStage Inherited (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean | undefined BaseUiItemsProvider  

Defined in

Last Updated: 30 January, 2025