UiItemsProvider Interface
Describes interface of objects that want to provide UI component to the running IModelApp.
Implemented by
- BaseUiItemsProvider
- StandardContentToolsUiItemsProvider
- StandardNavigationToolsUiItemsProvider
- StandardStatusbarUiItemsProvider
Properties
Name | Type | Description | |
---|---|---|---|
getBackstageItems Readonly | () => ReadonlyArray<BackstageItem> | undefined | Provides backstage items. | |
getStatusBarItems Readonly | () => ReadonlyArray<StatusBarItem> | undefined | Provides status bar items. | |
getToolbarItems Readonly | () => ReadonlyArray<ToolbarItem> | undefined | Provides toolbar items. | |
getWidgets Readonly | () => ReadonlyArray<Widget> | undefined | Provides widgets. | |
id Readonly | string | Id of provider. | |
onUnregister Readonly | () => void | undefined | Function called when the provider is unregistered. | |
provideBackstageItems Readonly | () => ReadonlyArray<BackstageItem> | undefined | Provides backstage items. | Deprecated |
provideStatusBarItems Readonly | (stageId: string, stageUsage: string) => ReadonlyArray<StatusBarItem> | undefined | Provides status bar items. | Deprecated |
provideToolbarItems Readonly | (stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation) => ReadonlyArray<ToolbarItem> | undefined | Provides toolbar items. | Deprecated |
provideWidgets Readonly | (stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection) => ReadonlyArray<Widget> | undefined | Provides widgets. | Deprecated |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.