BaseUiItemsProvider Class

Deprecated  in 4.17.0. Use UiItemsProviderOverrides to specify supported frontstages when registering the provider.

Base implementation of a UiItemsProvider. The base class allows the user to pass in a function that is used to determine if the active stage should be provided items. Derived provider classes should override the xxxInternal methods to provide items.

Extended by

Implements

Methods

Name Description
constructor(_providerId: string, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean): BaseUiItemsProvider    
onUnregister(): void Function called when the provider is unregistered.  
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): StatusBarItem[] Provides status bar items. Deprecated  
provideStatusBarItemsInternal(_stageId: string, _stageUsage: string, _stageAppData?: any): StatusBarItem[]    
provideToolbarItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): ToolbarItem[] Provides toolbar items. Deprecated  
provideToolbarItemsInternal(_stageId: string, _stageUsage: string, _toolbarUsage: ToolbarUsage, _toolbarOrientation: ToolbarOrientation, _stageAppData?: any): ToolbarItem[]    
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, stageAppData?: any): ReadonlyArray<Widget> Provides widgets. Deprecated  
provideWidgetsInternal(_stageId: string, _stageUsage: string, _location: StagePanelLocation, _section?: StagePanelSection, _stageAppData?: any): Widget[]    
unregister(): void    

Properties

Name Type Description
_providerId Protected string    
id Accessor ReadOnly string Id of provider.  
isSupportedStage (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean | undefined    

Defined in

Last Updated: 30 January, 2025