StandardContentToolsProvider Class
Deprecated in 4.17.0. Use StandardContentToolsUiItemsProvider instead. Supported frontstages can be specified when registering the provider.
Provide standard tools for the ContentManipulationWidgetComposer.
Extends
Methods
Name | Description | |
---|---|---|
constructor(providerId: string, defaultContentTools?: DefaultContentTools, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardContentToolsProvider | ||
provideStatusBarItemsInternal(_stageId: string, _stageUsage: string, _stageAppData?: any): StatusBarItem[] | ||
provideToolbarItemsInternal(_stageId: string, _stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): ToolbarItem[] | ||
register(providerId: string, defaultContentTools?: DefaultContentTools, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardContentToolsProvider Static | static function to register the StandardContentToolsProvider |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onUnregister(): void Inherited | BaseUiItemsProvider | Function called when the provider is unregistered. |
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): StatusBarItem[] Inherited | BaseUiItemsProvider | Provides status bar items. |
provideToolbarItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): ToolbarItem[] Inherited | BaseUiItemsProvider | Provides toolbar items. |
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, stageAppData?: any): ReadonlyArray<Widget> Inherited | BaseUiItemsProvider | Provides widgets. |
provideWidgetsInternal(_stageId: string, _stageUsage: string, _location: StagePanelLocation, _section?: StagePanelSection, _stageAppData?: any): Widget[] Inherited | BaseUiItemsProvider | |
unregister(): void Inherited | BaseUiItemsProvider |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_providerId Protected Inherited | string | BaseUiItemsProvider | |
id Accessor Inherited ReadOnly | string | BaseUiItemsProvider | Id of provider. |
isSupportedStage Inherited | (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean | undefined | BaseUiItemsProvider |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.